Fusion 6.32 requires a valid subscription license. The subscription date to use 6.32 build 1030 will need to be 26th March, 2012 or later. Download it here.

Cheers,
Sue